第4章
音楽を編集する
音符を入力したあとの修正作業は、ほとんどが選択ツールで行います。音符や小節を選んでから、それをどうするかを決めます。この章では、選択、コピーとペースト、移調、削除、項目の手動での移動、操作の取り消しについて説明します。
選択ツール
選択ツールは左のパレットのいちばん上にあります。⌘1(WindowsではCtrl+1)か、ツールメニューで選びます。再生が止まっているときは、Escでも選択ツールに戻ります。
パレットを持つツール(アーティキュレーション、表情記号、線、連符、反復記号とジャンプ、レイアウト)は選択ツールとまったく同じように選択でき、ツールを切り替えても選択範囲はそのまま残ります。
音符と小節を選択する
音符
- 音符をクリック:その音符を選択します(音も鳴ります)。
- ほかの音符を**⇧-クリック**:選択範囲に追加します。選択済みの音符を⇧-クリックすると選択から外れます。
- 何もない場所からドラッグ(または小節の空いている部分から):四角形に触れた音符を、複数の譜表にまたがって選択します。⇧を押しながらだと、すでに選択している音符に追加します。パレットを持つツール(アーティキュレーション、表情記号…)でも使えます。アーティキュレーションや強弱記号のキーを押したままドラッグすると、その音符にすぐ記号が付きます(記号とテキストを参照)。
和音の1つの音だけ
和音をクリックすると和音全体が選択されます。その中の1つの音符だけを扱うには、Speedy Entryのカーソルと同じように、和音が選択された状態でその符頭をもう一度クリックするか、最初から符頭を**⌥-クリック**(WindowsではAlt-クリック)します。その音符だけが青くなります。この状態では、↑ ↓、⇧↑ ⇧↓、+ −、Nはその音符だけを変更し、⌫はその音符を和音から取り除き(残りは選択されたまま)、コピーとカットもその音符だけが対象になります。ほかの符頭をクリックするとその音符に移り、それ以外の場所をクリックすると音符全体の選択に戻ります。キーボードでは、⌘↑と⌘↓(WindowsではCtrl+↑とCtrl+↓)で上または下の音符に移ります。和音全体が選択されているときは、いちばん高い音またはいちばん低い音を選びます。そのほかのコマンド(タイ、アーティキュレーション…)は和音全体に適用されます。Simple Entryでは、符頭を1回クリックするだけで選べます。
小節
- 小節の空いている部分をクリック:その譜表のその小節を選択します。
- ほかの小節を**⇧-クリック**:その小節まで、またクリックした譜表まで選択範囲を広げます。
- ← →:選択範囲を前または次の小節に移します。↑ ↓は上または下の譜表に移します(スコアの中で。隠れている譜表は飛ばします)。複数の小節や譜表を選択しているときは、ブロック全体が移動します。
- ⇧→ ⇧←(WindowsではShiftと矢印キー):選択範囲を次または前の小節まで広げます。⇧↓ ⇧↑は下または上の譜表まで広げます。Finaleと同じです。最初に選んだ小節は固定されたままなので、逆方向に戻ると選択範囲が縮み、さらに進むと反対側に広がります。
- ⌥-クリック(WindowsではAlt-クリック):すべての譜表のその小節を選択します。
- ⌘A(WindowsではCtrl+A)または編集 → すべてを選択:スコア全体を選択します。
- 小節をダブルクリック:その位置でSpeedy Entryに切り替わります。
選択した小節は、段ごとに角の丸い枠で表示されます。
選択した音符を変更する
音符(または小節。その場合は小節内のすべての音符が対象)を選択しているときは、キーボードで次の操作ができます。
| キー | 動作 |
|---|---|
| ← → | 前または次の音符(または休符)に移り、音を鳴らします。小節線を越えても移動します |
| ↑ ↓ | 調号に従って音符を1音度動かします(小節を選択しているときは⌥↑ ⌥↓、WindowsではAlt+↑ Alt+↓。矢印キーだけだと選択範囲が移動します) |
| ⇧↑ ⇧↓ | 音符を1オクターブ動かします(小節を選択しているときは⌥⇧↑ ⌥⇧↓) |
| + − | 半音上げる、または下げる(打楽器では同じ位置の別の音に切り替えます) |
| N | ナチュラル:調号のものも含め、シャープとフラットを取り除きます |
| 9 | 異名同音の書き換え:同じ音を別の名前で書きます(C♯ ↔ D♭) |
| Tまたは= | 次の音符とタイでつなぎます。もう一度押すと外します |
| P | 親切臨時記号:括弧付き、括弧なし、削除の順に切り替えます |
| / | 音符の前で連桁を切る、または前の音符とつなぎます |
| ; | 音符をアッチャカトゥーラ、アッポッジャトゥーラ、通常の音符の順に切り替えます |
| ⌫ | 削除します(下記を参照) |
音価、付点、タイ、アーティキュレーションはインスペクタでも変更できます。
右クリックメニュー
右クリック(Macでは⌃-クリックやトラックパッドの2本指クリックでも可)すると、ポインタの下にあるものを選択してから、そのメニューが開きます。
- 音符の上:アーティキュレーション、強弱記号、タイ、符頭、連桁、符幹を反転、親切臨時記号、異名同音の書き換え。続いてコードネーム、テキスト、歌詞、リハーサルマーク。最後にカット、コピー、ペースト、削除。複数の音符を選択しているときは、スラー、クレッシェンド、ディミヌエンドもあります。
- 小節の上(音符のない場所):コードネームとテキスト、調号、拍子記号、音部記号、その小節からの新しい段や新しいページ、代替記譜、小節の挿入や消去、クリップボード。
- コードネーム、強弱記号、テキスト、スラーの上:自動の位置、削除。コードネームは編集、スラーは反転もできます。
ほかの音符や小節と一緒にすでに選択されている音符や小節をクリックした場合、選択範囲はそのまま残り、メニューの項目は選択したものすべてに適用されます。Speedy Entryでは、右クリックするとカーソルがその音符に移ります。
コピー、カット、ペースト
コピーの対象は、選択した譜表の選択した小節と、その中にあるすべてのものです:音符、休符、レイヤー、アーティキュレーション、強弱記号、ヘアピン、テキスト、コードネーム、線、スラー、グリッサンド。
| コマンド | Mac | Windows |
|---|---|---|
| カット | ⌘X | Ctrl+X |
| コピー | ⌘C | Ctrl+C |
| ペースト | ⌘V | Ctrl+V |
| 複数回ペースト… | ⌥⌘V | メニューから |
| フィルタを指定してペースト… | ⇧⌘V | Ctrl+Shift+V |
これらのコマンドは、MacでもWindowsでも編集メニューにあります。
- コピーする小節を選択します(クリック、⇧-クリックで範囲を広げる、⌥-クリックですべての譜表)。
- コピーを選びます(またはカット。コピーしてから小節を空にします。小節は休符の入った状態で残ります)。
- ペースト先の小節をクリックするか、そこにSimple EntryまたはSpeedy Entryのカーソルを置きます。
- ペーストを選びます。
知っておくと便利なこと:
- ペーストすると、ペースト先の小節の内容は置き換えられます。スコアの終わりを越える場合は、小節が追加されます。
- 複数の譜表をコピーした場合は、クリックした譜表から下に向かってペーストされます。
- 音符は実音でコピーされるので、移調楽器にペーストすると、最初からその楽器の調で書かれます。
- ペースト先の小節は、コピーした小節と同じ長さの拍子でなければなりません。
- ペーストしたあとは、ペーストした音楽が選択されたまま残り、すべてを1回の操作で取り消せます。
- クリップボードは、別のウインドウや別の書類の間でも使えます。
- テキストフィールドに入力しているときは、⌘Cと⌘Vは音楽ではなくテキストをコピー・ペーストします。
小節の一部をコピーする
一部分だけ(2拍分、弱起で始まるフレーズ…)をコピーするには、小節ではなく音符を選択します。クリック、⇧-クリック、または四角形のドラッグで選びます。選択した最初の音符から最後の音符までの時間の範囲が、その範囲に触れるすべての譜表について、中にある休符、強弱記号、コードネーム、テキストと一緒にコピーされます。
ペーストは、Speedy Entryのカーソルの位置、選択した音符の位置、または⌘-クリック(WindowsではCtrl+クリック)した位置から行います。小節の途中や裏拍からでもかまいません。コピーした範囲は、ペースト先の同じ長さの範囲を置き換え、小節の残りの部分はそのまま残ります。
- 新しい位置で小節線をまたぐ音符は、分割されてタイでつながれます。
- 範囲の端で切られるペースト先の音符は短くなります。
- ペースト先の拍子記号が異なっていてもかまいません。
- 連符(3連符…)は分割できません。範囲が連符を切ってしまう場合は、Maestroがそのことを知らせ、ペーストしません。
音符を選択した状態でカットすると、その範囲をコピーして、元の場所には休符を残します。
複数回ペースト
編集 → 複数回ペースト…(Macでは⌥⌘V)は、コピーした音楽を何回繰り返すかをたずね、選択した小節から続けてペーストします。リフ、ドラムのグルーヴ、繰り返しの伴奏パターンに便利です。
フィルタを指定してペースト
編集 → フィルタを指定してペースト…(⇧⌘V。WindowsではCtrl+Shift+V)は、Finaleの編集フィルタにあたる機能です。音符と休符、アーティキュレーション、強弱記号とヘアピン、スラーとグリッサンド、歌詞、コードネーム、数字付き低音、テキストと記号、オクターブ線とテキスト線の中から、ペーストするものにチェックを入れます。Maestroはその選択を次回のために覚えておきます。
- 「音符と休符」をオンにした場合は通常どおりペーストされますが、チェックしなかったものはペースト先のまま残ります。たとえば、新しい音符に置き換えても、元の強弱記号や歌詞はそのまま残せます。
- 「音符と休符」をオフにした場合は、ペースト先の音符はそのまま残り、同じ位置から始まるコピー元の音符のアーティキュレーション、歌詞、スラーを受け取ります。コピーした範囲の強弱記号、コードネーム、テキスト、線は、元からあったものと置き換わります。第1ヴァイオリンのボウイングと強弱記号を第2ヴァイオリンにコピーしたり、あるセクションのアーティキュレーションを同じリズムの別のセクションにコピーしたりするときに使います。
ペーストのあとは変更された音符が選択されたまま残り、すべてを1回の操作で取り消せます。
クリックやドラッグでコピーする
Finaleと同じように、選択ツールではクリップボードを使わずにコピーできます。小節(小節の一部なら音符)を選択してから、次のどちらかを行います。
- 選択範囲をドラッグしてコピー先まで運びます。選択した音符、または選択した小節内の空いている場所をつかみ、コピー先でマウスボタンを放します。
- または、Macでは⌘(WindowsではCtrl)を押しながらコピー先をクリックします。
どちらの場合も、小節の上にグリッドが表示されます。拍の番号と、裏拍ごとの短い線です。コピー先はグリッドに吸着し、ラベル付きの線(「小節5、2½拍目」)がコピーの入る位置を示します。音符をクリックすると、その音符の頭からコピーされます。ドラッグ中は、4、8、6でグリッドの間隔(拍、8分音符、16分音符)を変更でき、escで中止します。
選択範囲は元のまま残るので、ほかの場所にも続けてコピーできます。小節全体を表拍にコピーした場合は小節のまま(同じ拍子記号で)コピーされます。裏拍にコピーした場合は、小節の一部をコピーするときのルールに従ってずれて入ります。コピーは1回ずつ取り消せます。
移調
**編集 → 移調…**は、選択した音符、または選択した譜表の選択した小節を移調します。ダイアログで次のどちらかを選びます。
- 音程で:短2度からオクターブまでの音程を、上または下に。必要なら1〜2オクターブを加えられます。
- 別の調へ:移調先の調と方向(最も近い調、上、下)。
綴りは正しく処理され(B♭を長3度上げるとD)、コードネームも音符と一緒に移調され、打楽器はそのまま残ります。
すべての譜表を選択している場合(⌥-クリックまたは⌘A)は、調号も変更にチェックを入れられます。調号は移調した範囲だけで変わります。シャープやフラットが7個を超える場合は、異名同音の調が使われます。
削除
- 音符を選択しているときは、⌫(WindowsではDeleteでも可)でその音符を小節から取り除きます。音符を休符に変えたい場合は、Speedy Entryで⌫を使います。
- 小節を選択しているときは、⌫で選択した譜表のその小節を空にします(⌥-クリック、WindowsではAlt-クリックで選んだ場合はすべての譜表)。音部記号は残ります。
- 小節そのものをスコアから取り除くには、書類 → 小節 → 選択した小節を削除(⌘⌫。WindowsではCtrl+Delete)を使います。楽器と譜表も参照してください。
項目を手動で移動する
Maestroは強弱記号、テキスト、線を自動で適切な位置に配置しますが、何かを少し動かしたいこともあります。選択ツールを使うと、強弱記号、テキスト、リハーサルマーク、コードネーム、スラー、ヘアピン、オクターブ記号、テキスト線をマウスでつかんでドラッグできます。
項目をクリックしたあとは、次のキーが使えます。
| キー | 動作 |
|---|---|
| ← → ↑ ↓ | 4分の1スペース動かします |
| ⇧+矢印キー | 1スペース動かします |
| ⌫ | 項目を削除します |
| Esc | 選択を解除します |
編集 → 自動の位置(Macでは⌥⇧⌘R)は、選択した項目を元の位置に戻します。
移動量は自動の位置からの相対値なので、レイアウトが変わっても項目は音楽についていきます。移動は書類と一緒に保存され、パートにも反映されます。
インスペクタ
表示 → インスペクタ(⌥⌘I。WindowsではCtrl+I)を選ぶと、右側に列が開き、選択したもの、またはSpeedy Entryのカーソルの下にある音符の属性が表示されます。変更はその場で行われ、ほかの操作と同じように取り消せます。
- 音符:音高、小節とレイヤー、音価と付点、次の音符へのタイ、アーティキュレーション(クリックでオン・オフ)、連符。複数の音符を選択しているときは、変更がすべての音符に適用されます。
- 小節:その小節からの調号と拍子記号、反復の開始と終了、新しい段と新しいページ。
- 譜表:名前と略称、楽器、音色、移調、譜表のサイズ、上の譜表との間隔、打楽器、ギターダイアグラム。
- 書類:タイトル、作曲者、メトロノームのテンポ、ページ設定。
取り消しとやり直し
すべての変更は1つずつ取り消すことができ、やり直すこともできます。
| コマンド | Mac | Windows |
|---|---|---|
| 取り消す | ⌘Z | Ctrl+Z |
| やり直す | ⇧⌘Z | Ctrl+YまたはCtrl+Shift+Z |
Macでは、メニューに操作の名前が表示されます(「移調を取り消す」)。ツールバーにも「取り消す」と「やり直す」のボタンがあり、ツールチップに操作の名前が表示されます。大きな操作(ペースト、移調、ハーモナイズ)は1回で取り消せます。