第10章
ファイル
Maestroはスコアを独自のフォーマットで保存しますが、Finale、MuseScore、MusicXML、MIDIのファイルや、楽譜作成ソフトから書き出されたPDFも開けます。また、PDF、 PNGとSVGの画像、MusicXML、MIDI、オーディオに書き出せます。この章では、開き方と保存、ほかのソフトのファイルを開いたときの扱い、 自動保存とバックアップで作業を守る方法、セットリストの作り方を説明します。
コマンドはMacでもWindowsでもファイルメニューにあります。
スコアを開く
- ファイル → 開く…(⌘O、WindowsではCtrl+O)を選びます。
- または、ファイルをダブルクリックするか、Maestroのアイコン(Mac)やMaestroのウインドウ(Windows)にドラッグします。
- 最近開いたファイルはファイル → 最近使った項目を開くにあります。
開いたスコアは、同じウインドウのタブとして並びます。MacではmacOSのタブで、すでに開いているファイルをもう一度開くと、 重複して開くのではなく、そのタブが前面に出ます。WindowsではCtrl+TabとCtrl+Shift+Tab、または 表示 → 開いている書類でタブを切り替え、Ctrl+Wか×でタブを閉じます。
フォーマット
| フォーマット | 拡張子 | 開く | 保存/書き出し |
|---|---|---|---|
| Maestro | .maestro | 可(古い.partituraも) | 可 |
| Finale | .musx | 可 | 可 |
| Finale(旧フォーマット) | .mus | 可 | 不可 |
| MuseScore 3と4 | .mscz, .mscx | 可 | 不可 |
| Sibelius, Dorico | .sib, .dorico | 不可:MusicXMLへの書き出し方をMaestroが説明します | 不可 |
| MusicXML | .musicxml, .xml | 可 | 可 |
| 圧縮MusicXML | .mxl | 可 | 可 |
| MIDI | .mid, .midi | 可 | 可 |
| 楽譜作成ソフトから書き出したものなら可 | 可 | ||
| 画像 | .png, .svg | 不可 | 可 |
| オーディオ | .m4a, .wav | 不可 | 可 |
Finaleのファイル
Maestroは**.musx**ファイルを、MusicXMLを経由せずに直接読み込みます。譜表とその名前、音部記号、調号、拍子、 音符、和音、休符、レイヤー、連符、ブレースとブラケット、移調楽器、打楽器マップ付きのドラムセット、装飾音、 アーティキュレーション、強弱記号、スラー、ヘアピン、テキスト、リハーサルマーク、コードネーム、歌詞、反復記号、 番括弧、ジャンプ、リズムスラッシュ、さらに連桁、複合拍子(3+3+2/8)、異名同音で書かれた音符 (C♯ではなくD♭)、トリル、そしてFinaleで表示されていればコードネームの上のギターダイアグラムも読み込まれます。ページのフォーマットとレイアウトも読み込まれ、 段とページはFinaleのとおりになります。各段には、Finaleで表示されていた譜表が表示されます(たとえば合唱だけ、あるいは会衆とオルガンだけ)。ただし、それはその段で休んでいる譜表に限られ、音符のある譜表が隠れることはありません。Finaleで非表示にしていた拍子(自由な聖歌、イントネーション)は非表示のままで、Finaleが段の終わりの予告拍子や予告調号を省いていた箇所では、Maestroも省きます。Finaleで横に並んでいた段がページに収まらない場合は、Maestroが下に並べ直し、ほとんど空のページを残しません。よりコンパクトなMaestroのレイアウトに切り替えるには、 レイアウトとプリントを参照してください。ファイルは音楽フォントとテキストのフォントも元のまま開きます。これらのフォントは Maestroに含まれているので、Finaleがインストールされていなくても、見た目はFinaleと同じです( 音楽フォントとテキストのフォントを参照)。
「ボイス2」の音符(小節の空いているレイヤーに入ります。ボイス2を参照)や、非表示の音符と休符も読み込まれます。 FinaleではFinale Numericsフォントの歌詞として書いていた数字付き低音は、同じ音符の下に本物の数字付き低音として 読み込まれます(**記譜 → コードネームと歌詞 → 数字付き低音…**を参照)。Eisenach(DotMusのスコア、たとえばバッハの カンタータで使われているフォント)で書かれたものも読み込まれます。そのほかの通奏低音用フォントでは単純な数字だけが読み込まれ、 足りない数は通知に表示されます。
読み込めなかったものがあると、ファイルを開いたあとに通知でその内容と数が表示されます。たとえば、カスタムの 線(破線、括弧)や描画された記号などです。
うまく開けないファイルがありますか? ファイルを開いたあとの通知には**ファイルを報告…**ボタンがあり、同じコマンドが **ヘルプ → うまく開けないファイルを報告…**にもあります(ファイルを開いていればそのファイルが提案され、開いていなければ選択します)。 Maestroの開発者あてに、ファイル、バージョン、システム、開いたときの通知をまとめたメッセージが用意されます。うまくいかない点を書いて、 ご自分で送信してください。Macでメールを使っている場合はファイルがすでに添付されています。それ以外の場合は、Finderまたは エクスプローラーでファイルが選択された状態で表示されるので、メッセージにドラッグしてください。ファイルはMaestroの修正にだけ使われ、それ以降は新しいバージョンのたびに そのファイルが正しく開けるかどうかが確認されます。
Finaleがバージョン25(2018年)まで使っていた旧フォーマットの**.musも開けます。譜表、音符、強弱記号、テンポ付きの発想記号、アーティキュレーション、スラー、ヘアピン、反復記号、 番括弧、打楽器、レイアウト、そして歌詞**が読み込まれます。.musのコードネームはまだ読み込まれません。必要な場合は、ファイルを Finaleで開いて.musxとして保存するか、MusicXMLに書き出してください。
.musでは番の番号はその歌詞の番号で、Finaleでは行を手作業で譜表に近づけています。Maestroは、重ならない番(たとえば 別の楽章の番)は同じ行に、同時に歌う番は別の行に配置します。
Finale 2000〜2006の.musは内部の形式がより古いため、タイトル、作曲者、編曲者は音楽のある最初のページのテキストから 取り出されます。レイアウトと打楽器は読み込まれず、Maestroが自分でレイアウトします。1990年代初めのごく初期のFinaleで 保存されたファイルは開けません。
MuseScoreのファイル
MaestroはMuseScore 3と4のファイル(.mscz、および圧縮されていない.mscx)を直接開けます。譜表とその名前、音部記号、 調号、拍子、弱起小節、音符、和音、休符、4つの声部、入れ子も含めた連符、ブレースと ブラケット、移調楽器、ドラムセット、タブ譜、装飾音、アーティキュレーション、強弱記号、スラー、ヘアピン、 オクターブ記号、テキスト線、グリッサンド、メトロノーム記号、リハーサルマーク、コードネーム、番ごとの歌詞、 反復記号、番括弧、セーニョ、コーダとジャンプ、小節の反復記号、リズムスラッシュが読み込まれます。ページの フォーマットや、段とページの区切りも読み込まれます。
読み込めなかったもの(運指、ギターダイアグラム…)があると、ファイルを開いたあとに 通知で一覧表示されます。MuseScore 2以前のファイルは、先にMuseScore 3か4で開いて保存し直してください。
MIDIファイル
MIDIファイルは本物のスコアになります。トラックごとに1つのパートが作られ、トラック名と、General MIDIのサウンドに対応する楽器 (その移調も含みます。たとえばB♭トランペット)が付きます。ピアノは2段の譜表に、チャンネル10は ドラムセットの譜表に入ります。タイトル、テンポ、拍子、調はファイルから取り込まれ、テンポの変化は「♩ = …」の表示になります。
音符は録音と同じように採譜され、設定 → MIDIで選んだクオンタイズのグリッドと3連符の認識が使われます (MIDIキーボードを参照)。時間がフレーム単位(SMPTE)のMIDIファイルは 読み込めません。
楽譜作成ソフトから書き出したPDF
MuseScore、Finale、Sibelius、LilyPond、Maestroなどの楽譜作成ソフトで作られたスコアのPDFしか手元にない場合は、 ほかのファイルと同じように**ファイル → 開く…**で開いてください。こうしたPDFでは、音楽記号は音楽フォントの文字 (BravuraやLeland、FinaleのMaestro、Jazz、Broadway Copyistといった古いフォント、SibeliusのOpusやReprise、 LilyPondのEmmentalerなど)で、譜線、符幹、連桁は線になっています。Maestroはそれらを画像認識なしで直接読み取るので、数秒で終わり、 Mac App Store版でも使えます。
音価付きの音符、和音、休符(複数小節休符も)、臨時記号、タイとスラー、連符、 同じ譜表の2つの声部、音部記号、調号、拍子、複縦線と反復記号(1番・2番括弧)、セーニョ、コーダ、D.C.、D.S.、Fine、 オクターブ記号(8va、8vb、15ma:音符は実際の音の高さに戻ります)、トリル、モルデント、ターン、アルペジオ、番ごとの歌詞、 コードネーム、強弱記号、ヘアピン、アーティキュレーション、フェルマータ、リハーサルマーク、 メトロノーム記号、タイトルと作曲者が読み込まれます。一部の段で非表示になっている空の譜表も、楽器名を手がかりに 元の位置に戻ります。スキャンしたスコアと同じように、スコアの横に元のPDFが開きます(下記を参照)。
スラッシュで書かれた音符(ギターのリズム記譜)や打楽器の音高は再現できません。タブ譜の譜表は、 同じ音符が上の譜表にあるため読み飛ばします。楽器ごとに続けて並んだパート譜のPDF(各パートがタイトル付きの新しいページから始まるもの)は、 パートの小節数が同じであれば、すべての楽器をまとめたスコアになります。PDFがスキャンしたものの場合は、Maestroがそのことを知らせるので、下で説明する認識機能を使えます。
スキャンしたスコア(OMR)
**ファイル → スキャンしたスコアを読み込む…**は、PDFやページの画像(PNG、JPEG、TIFF)から 音符を認識します。認識には、無料のオープンソースの光学楽譜認識(OMR、Optical Music Recognition)ソフト Audiverisを使います。初回は、Maestroが公式サイトからダウンロードして Maestroのフォルダにインストールすることを提案します(約85MB、AudiverisのAGPLライセンスへの同意が必要です)。すでにインストール済みの場合は、 「探す…」で場所を指定できます。
- PDF、またはページの写真を順番どおりに選びます。それらが1つのスコアになります。 PDFが楽譜作成ソフトから書き出されたものであれば、MaestroはAudiverisを使わずに直接読み取ります。
- 初回は、Audiverisが歌詞、コードネーム、タイトル、作曲者を読み取るための言語データ(1言語あたり15〜25MB)の ダウンロードを提案します。ダウンロードせずに続けることもでき、その場合は音符だけが読み込まれます。
- 認識には1ページあたり数秒かかり、進み具合はウインドウ(Windowsではステータスバー)に表示されます。 Audiverisが段ごとに分けてしまう楽器(最初の段では正式名、以降の段では略称)は、1つの譜表にまとめ直されます。
認識が終わると、スコアの横に元のスキャンが開きます(もう一度開くには表示 → 元のスキャン)。 カーソルのある小節や選択している小節がページ上で強調表示され、ページも自動で 切り替わります。スキャン上の小節をクリックすると、スコアでその小節が選択されます。スキャンは書類と一緒に保存されます。 修正が終わったら、**書類 → 書類からスキャンを削除…**でファイルを軽くできます。
認識の前に、Maestroは横向きや上下逆さのページを正しい向きに回し、傾いたページを(五線を手がかりに約8度まで)まっすぐにし、写真や影のあるコピーの背景を均一にします。 少し斜めにスキャンされ、Audiverisだけでは読めないページも、まっすぐなページと同じように読み込まれます。
結果は必ず確認してください。鮮明な印刷譜を300dpiでスキャンしたものなら非常によく認識できます。 ひどく色あせたコピー、ジャズのスコアの「手書き風」フォント、ギターのタブ譜(読み取れません)では精度が落ちます。 音部記号や拍子が間違っていたら、最初に直してください。後に続くすべての音符がそれに左右されます。Mac App Store版の Maestroには、ほかのソフトを起動できないため、このコマンドがありません。Microsoft Store版では、MaestroはAudiverisを自動ではインストールしません。 「Audiverisのウェブサイトを開く」でダウンロードページが開き、インストールすればMaestroが自動で見つけます。
保存
- ファイル → 保存(⌘S、WindowsではCtrl+S)
- ファイル → 名前を付けて保存…(⇧⌘S、WindowsではCtrl+Shift+S)
Finale、MuseScore、MusicXML、MIDIのファイルが上書きされることはありません。最初に保存するときに、Maestroのフォーマットで スコアを保存する場所を尋ねられます。保存していない変更があるままスコア(またはMaestro)を閉じようとすると、保存するかどうかを確認されます。
書き出し
| コマンド | Mac | Windows |
|---|---|---|
| PDFを書き出し… | ⇧⌘P | ファイルメニューから |
| 画像を書き出し… | メニューから | ファイルメニューから |
| MusicXMLを書き出し… | ⇧⌘E | ファイルメニューから |
| 圧縮MusicXML(.mxl)を書き出し… | メニューから | ファイルメニューから |
| Finale(.musx)を書き出し… | メニューから | ファイルメニューから |
| MIDIを書き出し… | メニューから | ファイルメニューから |
| オーディオを書き出し… | ⌥⇧⌘E | ファイルメニューから |
- PDF:ページ表示のとおりのページです。パートの表示では、そのパートが書き出されます。
- MusicXML:スコアをMuseScore、Dorico、Sibelius、Finaleに渡すためのものです。ファイルにはレイアウト (段、ページ、譜表間の距離)も含まれるので、相手のソフトでも同じ段組みで開けます。パートの表示では、 そのパートが書き出されます。圧縮フォーマットの.mxlはサイズが小さく、同じソフトで読み込めます。
- Finale(.musx):Finaleを使い続けている人のためのものです。ファイルはFinale 27で開け、音符、スラー、アーティキュレーション、 強弱記号、ヘアピン、テキスト、歌詞、コードネーム、反復記号、番括弧とジャンプ、ドラムセット、固定した符幹の向き、スラッシュ記譜と小節の反復記号、オクターブ記号、 ペダル、「cresc. – – –」や「rit.」のような線、グリッサンド、トレモロとアルペジオ、ブレースとブラケット、テンポ表示とリハーサルマーク、各楽器のサウンドが含まれ、 Maestroのレイアウト(用紙、段、ページ、音符の間隔)もそのまま引き継がれます。パート譜はFinaleの 書類 → パートを管理で作成します。パートの表示では、そのパートが書き出されます。
- MIDI:鳴るとおりの音符に、タイトル、トラック名、調号、ミキサーの音量とパン、スウィング、 テンポの変化、コードネームからの伴奏が含まれます。Maestroに読み込み直すと、同じ音符に戻ります。
- 画像:PNGまたはSVGで、文書、プレゼンテーション、メッセージに使えます。 画像を書き出すを参照してください。
- オーディオ:M4AまたはWAVで、スコア全体、パートごと、または各パートを抜いた伴奏を書き出せます。 オーディオに書き出すを参照してください。
プリントや、PDFやMusicXMLでのパートの抽出については、レイアウトとプリントを参照してください。
画像を書き出す
**ファイル → 画像を書き出し…**は、音楽をページ表示で見えるとおりに画像として保存します。 スクロール表示で作業しているときも同じです。ウインドウで次の項目を選びます。
- フォーマット:文書、メッセージ、ウェブサイト向けの通常の画像であるPNG、またはどのサイズでも くっきり表示されるベクター形式のSVG。
- 書き出し:表示中のページ、すべてのページ(1ページごとに1ファイル)、または選択した小節。
- 解像度(PNG):150、300、600dpi。高いほど画像は鮮明になり、ファイルは大きくなります。
- 透明な背景:紙の白をなくし、色の付いた背景に音楽を載せるためのものです。
一部の小節だけを書き出すには、先に選択ツールで選択しておきます(音符を選択しても かまいません。その音符のある小節が対象になります)。画像はその譜表だけを切り取り、強弱記号や テキストのための余白を少し付けます。選択範囲が次のページに続いている場合は、ページごとに1枚の画像になります。何も選択していないときは、 選択した小節は選べません。
ファイル名はタイトルから付けられます。複数ページの場合は「1ページ」「2ページ」…が、小節の場合は「第5小節」や 「第5–12小節」が加わります。ファイルが複数になる場合、Macでは保存先のフォルダを選びます。Windowsでは最初のファイルの 名前を選び、ほかのファイルは同じフォルダに保存されます。
パートの表示では、そのパートが書き出され、ファイル名にもパート名が入ります。選んだ設定は 次回のために記憶されます。
自動保存とバックアップ
設定 → 一般のバックアップセクションで設定します(MacではMaestro → 設定…、Windowsでは 編集 → 設定…)。
- 自動保存:しない(通常)、1分ごと、2分、5分、10分ごと。一度保存したことのあるMaestro書類にだけ 適用され、読み込んだファイルには適用されません。
- 保存のたびに以前のバージョンのコピーを残す(デフォルトでオン):書類を上書きする前に、 Maestroが以前のバージョンを保管します。各書類について最新の5つのコピーを残します。
- **バックアップを表示…**は、バックアップのフォルダをFinderまたはエクスプローラーで開きます。
各コピーの名前には、保存した日時が入っています。バージョンを復元するには、**開く…**で開いて 新しい名前で保存してください。
Maestroが突然終了したときは
次に起動したときにMaestroがそのことを知らせ、クラッシュレポートを送ることを提案します。レポートには 技術的なデータ(バージョン、システム、問題が起きたプログラム内の箇所)だけが含まれます。
- **メールで送信…**はレポート付きのメッセージを用意します。何をしていたかを書き足して送信してください。
- レポートを表示は、レポートのフォルダ(Maestroのサウンドの隣にある「Arresti anomali」)を開きます。ファイルを 手作業で添付するときに使います。
- 今はしないは何もしません。そのレポートが再び提案されることはありません。
最近使った書類
ファイル → 最近使った項目を開くには、最近開いたり保存したりしたファイルが表示されます。 いくつ記憶するかは設定 → 一般で選べます。
Macではさらに:
- 移動したり名前を変えたりしたファイルも見つかります。削除したファイルは一覧から消えます。
- 同じ名前のファイルが2つあるときは、フォルダも表示されます。
- メニューを消去で一覧を空にできます。
- 同じ最近使った項目がDockのメニュー(Maestroのアイコンを右クリック)にも、**新規スコア…**と一緒に表示されます。
セットリストのPDFとオーディオ
**ファイル → セットリスト(PDFとオーディオ)…**は、複数の曲を1つのPDFにまとめます。ライブや曲集に便利です。
- 曲(Maestro、MusicXML、Finale、MuseScore、MIDIのファイル)を追加します。ウインドウにドラッグしてもかまいません。
- 矢印ボタンや行のドラッグで並べ替え、不要な曲は外します。
- 曲集のタイトルを入力し、冒頭に目次を入れるかどうかを選びます。
- 内容として、スコア全体かパートを選びます。
- PDFを作成します。Windowsでは、セットリストを直接プリントすることもできます。
PDFは目次(各曲のタイトル、作曲者、ページ)で始まり、ページ番号はすべての曲を通して 続きます。一覧、タイトル、選んだ設定は次回のために記憶されます。
楽器のパート
楽器の名前を、名前の一部だけでも(「Trumpet」「Sax」)入力すると、各曲からそのパートが抽出され、 演奏者がそれぞれ自分の曲集を持てます。名前はほかの言語でも検索されます。イタリア語の「Tromba」でも「Trumpet 1」が見つかり、 「Sax」ではすべてのサクソフォーンが見つかります。そのパートがない曲は飛ばされ、最後に一覧表示されます。
セットリストのオーディオ
セットリストのウインドウの**オーディオを書き出し…**では、各曲を再生と同じように演奏した聴くための音源を、M4Aまたは WAVで、メトロノームの有無を選んで作れます。次のどちらかを選べます。
- 曲ごとに1ファイル:一覧の順に番号が付きます(「01 - Autumn Leaves」)。
- 1つのファイル:曲と曲の間に間隔(0〜20秒)を入れ、隣に各曲の開始時刻(分)を記したテキストの一覧が 付きます。
パートを選んでいる場合は、そのパートを抜いた伴奏も書き出せます。それに合わせて演奏してライブの練習ができます。 パートだけを書き出すこともできます。